Einsatzleiterwiki

Das elektronische Einsatzleiterhandbuch

Benutzer-Werkzeuge

Webseiten-Werkzeuge


wiki:hilfe:voraussetzungen

Auf dieser Seite sehen Sie die schreibgeschützte und geprüfte Version eines Artikels aus dem Einsatzleiterwiki-Projekt. Wenn Sie einen Artikel bearbeiten bzw. am Projekt aktiv mitarbeiten möchten, so besuchen Sie bitte das bearbeitbare Wiki. Für weitere Informationen zum Projekt allgemein rufen Sie bitte diese Seite auf.

Systemvoraussetzungen

Die Voraussetzungen beziehen sich eher auf die Software die installiert werden muss. An die Hardware werden nur sehr geringe Anforderungen gestellt. Selbst mehrere Jahre alte Computer erfüllen die Hardware-Anforderungen problemlos.

Um das Einsatzleiterwiki zu betreiben werden folgende drei Dinge benötigt. Wenn Sie das Wiki über das automatische Installationsprogramm installieren wird die Server-Software und PHP automatisch mitinstalliert.

1. Webserver mit PHP-Unterstützung

Der Apache-Server wird empfohlen, aber auch auf den meisten anderen bekannten Servern wird von einer problemlosen DokuWiki-Integration berichtet.

2. PHP 5.3.3 oder höher.

Es wird mindestens PHP 5.3.3 benötigt. Eine höhere Version ist aber noch besser.

Folgende Einstellungen/Programme werden empfohlen:

  • PHPs GD Erweiterung für libGD 2 (eine Grafikbibliothek) wird empfohlen, aber ist nicht zwingend notwendig
  • DokuWiki sollte in PHPs Safe Mode laufen, abhängig von der Konfiguration wird möglicherweise der safemodehack benötigt
  • DokuWiki ist dafür ausgelegt, ohne die register_globals-Konfiguration von PHP zu laufen.
  • Wenn das E-Mail-Registrierungsverfahren für neue Benutzer gewünscht ist, muss PHP eine funktionierende Mail-Konfiguration haben. Alternativ kann das SMTP-Plugin verwendet werden.

3. Einen anständigen Web-Browser

Jeder Browser der letzten paar Jahre sollte funktionieren. Mit Firefox sollten gute Erfahrungen zu machen sein.

Zusätzliche Plugins können darüber hinaus weitere Voraussetzungen besitzen, die Standard-Plugins die mit dem Einsatzleiterwiki mitgeliefert werden funktionieren aber mit den genannten Anforderungen.

Quellenangabe

  • de:requirements, veröffentlicht unter der CC Attribution-Share Alike 3.0 Unported-Lizenz
Cookies helfen bei der Bereitstellung von Inhalten. Durch die Nutzung dieser Seiten erklären Sie sich damit einverstanden, dass Cookies auf Ihrem Rechner gespeichert werden. Weitere Information

Diskussion

Geben Sie Ihren Kommentar ein. Wiki-Syntax ist zugelassen:
 
wiki/hilfe/voraussetzungen.txt · Zuletzt geändert: 19.10.2015 17:32 von christoph_ziehr